Utopia Temple
Main Forum Page Register an Account for Free! Calendar Frequently Asked Questions about this Board View New Posts Advanced Search Login
  Utopia Temple Forums > Utopia Angel > Known Bugs & FAQ

« Previous Thread | Next Thread »
  Post New Thread Reply
Author Thread
Administrator
Posts: 7868/8385
(26-May-2008 at 12:14)


lightbulb Forum Agent Common Problems

What is this Forum Agent?

The Forum Agent is a module of Utopia Angel, for automatically posting intel (CB, SoM, Survey and SoS) into external message boards. The Forum Agent supports many message boards which are available on the Internet, such as phpBB, vBulletin, Invision Board, ezboard, and so on.

Overview: What is the Forum Agent?

NOTE: In this section, we assume that you have read and understand how the Forum Agent works.


Self-SoM not added automatically to the Forum Agent queue

First make sure that the option to automatically add intel to the Forum Agent queue is checked in the Forum Agent Settings menu, and that the option to exclude intel from your own kingdom is cleared. To access the Forum Agent Settings menu, use one of these ways:


- Main Menu -> Settings -> Special Agents -> Forum Agent
- Main Menu -> Forum Agent -> Settings

Assuming the above settings are correct, this problem happens if Utopia Angel does not know your province name, since this information is not included in the page. To rectify this, simply copy your Throne page. Consecutive self-intel will be automatically linked to your account.


Error: "Unrecognized forum type!"

This happens when using an unsupported forum type. For a list of supported boards, click here.

NOTE: If you're getting this error with Utopia Pimp, you have set it incorrectly. Read below on how to set it right.


How to set up Utopia Pimp?

For instructions on how to set up the Forum Agent to use Utopia Pimp, click here.


Utopia Pimp: "API does not comply to the protocol standard"

When using Utopa Pimp, you may encounter this error when posting a SoM. The problem originates from a bug in Utopia Pimp! The SoM itself is posted successfully in Utopia Pimp, however the Forum Agent doesn't get confirmation for this as it should, and therefore assumes that there is a problem posting the intel, and leaves it in the queue for future processing.

Zanzibar claims that this problem also occurs when sending multiple intel items from the queue, regardless of their type. In this case, the last item in the queue will be reported as erroneous and remain in the queue for future processing. This has not been confirmed by me yet.

The preferred solution is to contact the creator of Utopia Pimp, and request to fix the problem on his end!
(Email: [email protected], AIM: utopiapimp, MSN: [email protected], ICQ #12184913).

A temporary workaround is to tell the Forum Agent to purge unsent entries quicker than normally. The default setting is 5 days, you may decrease it to 1 day, to reduce the number of failed iterations. To do so, open the Forum Agent Settings menu, using one of these ways:

- Main Menu -> Settings -> Special Agents -> Forum Agent
- Main Menu -> Forum Agent -> Settings

Change the "Purge unsent entries after x days" to the wanted value.

Update: Utopia Angel v1.90 Beta 2 and up is able to work around Utopia Pimp's bug. A warning message will still appear, however the intel is removed from the queue.


Utopia Pimp: "Invalid cb entered"

Starting with Utopia Angel v1.92 Alpha 1, you may encounter this error when posting intel of type Throne/CB, either manually or though the Forum Agent. The problem originates from a bug in Utopia Pimp! Utopia Pimp was not updated to recognize a change in the CB report format, and therefore rejects it.

The preferred solution is to contact the creator of Utopia Pimp, and request to fix the problem on his end!
(Email: [email protected], AIM: utopiapimp, MSN: [email protected], ICQ #12184913).

A temporary workaround is to remove the new part of the report that confuses Utopia Pimp. Here is how to do it:

- Main Menu -> Settings -> Formatter Settings -> CB Formatter
- Under "Output Customization", scroll down and uncheck "Networth Table"
- Click "OK" to confirm and close the window

Update: Utopia Angel v1.92 Alpha 3 and up is able to work around Utopia Pimp's bug (when using the Forum Agent). A warning message will appear, but the CB will be posted successfully (minus the unsupported layout bits). For manual posting, the above solution still applies.

Brother Green, Utopia Angel creator.

Last edited by Brother Green, 08-Aug-2008 at 19:17.
#1  
View Public Profile Find more posts by Brother Green Add Brother Green to your Buddy List Reply with Quote
  Reply

Thread Tools
Display Modes

Forum Jump:

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forum Agent Carry Over Settings Debello Options Discussions and Suggestions 0 02-Oct-2004 21:41
Forum Agent: 2nd level forum not found Lord Satan Report Bugs and Problems 4 20-Dec-2003 04:08
Forum Agent: some extension ideas Blood Raven Options Discussions and Suggestions 0 25-Jun-2003 21:53
Forum agent - phpbb and different templates Hogyt Report Bugs and Problems 1 22-Mar-2003 05:39


All times are GMT+1. The time now is 18:39.

Powered by vBulletin (modified)
Copyright ©2000-2006, Jelsoft Enterprises Ltd.