Utopia Temple Forums

Utopia Temple Forums (https://forums.utopiatemple.com/index.php)
-   General Site Discussions (https://forums.utopiatemple.com/forumdisplay.php?f=13)
-   -   Downtime and new server (https://forums.utopiatemple.com/showthread.php?t=78866)

Brother Green 17-Mar-2012 08:57

Downtime and new server
 
In the last 3 days, Utopia Temple was unavailable on the web. The reason is pretty straight, yet unfortunate. After 11 years of activity, our dedicated server decided it's time to retire, which manifested in a massive hardware failure.

Since no spare parts were available on site, a new server has been purchased, and is on its way to the hosting company. Unfortunately, waiting for its arrival, and then assembling, installing and configuring it would take at least another week.

Since we didn't want to be offline that long, we decided to set up the site from a backup on another host for now. That's where two more problem arose: the backup and the new host.

The backup: The old server performed daily backups which were stored locally, to which we had no access (the RAID array refused to mount on another machine). The latest backup we had access to was a week old. So we had 3 options: wait till we have access to the latest backup, and remain offline till then; use the week-old backup in read-only mode, until we can replace it with the latest backup; use the week-old backup in normal mode, and then break our heads if and how to merge the missing data from the latest backup once we regain access to it. We decided to go with the third option, and probably give up on the missing data. Our forum's activity is low lately, so the missing posts are probably just a few and not worth the headache of developing a merging mechanism.

The server: We moved from a dedicated server to a shared hosting environment. For those who are not familar with these terms, it means that we used to have access to all of the server's resources (particularly CPU and memory), whereas now we have to share those with thusounds of other websites which are hosted on the same server with us. At best, it means slower loading pages, at worst it means pages not loading at all ("white/blank pages"). If you encounter those, please let us know what you did to get them and we will look into it.

We were also forced to quickly upgrade our code from PHP4/MySQL4 to PHP5/MySQL5. This is usually a good thing, but we would have preferred doing it at our own pace in a controlled environment and with more testing. On the other hand, if this crash hadn't forced us, we probably wouldn't have done it at all ("if it ain't broke, don't fix it")!

So to recap:
1. Our dedicated server retired itself to a better place (and in smaller pieces).
2. We migrated to a less-capable server, running software that we hadn't had the chance to test thoroughly.
3. Several days-worth of data is missing.
4. Please report any problems you encounter so we could address them.

I want to thank Dom of Tyrall Networks for being such a great host and friend over the years! :)

BrandonC 17-Mar-2012 22:10

So is the move to the new host permanent, or just until the new server is up?

Lunor 17-Mar-2012 22:21

I never realized just how often I click my UtopiaTemple bookmark until the last day or so, when it'd give me a popup.

Turns out whenever I'm done touring my bookmarks, I go to UT. It's not even a conscious thing.

Anyway I'm glad you're back :)

Greeney 18-Mar-2012 03:53

If people are still going to UtopiaTemple.com (instead of forums.utopiatemple.com) they won't realize the forum is open.

Swifty 18-Mar-2012 04:12

The main page links to the forums doesn't it?

Brother Green 18-Mar-2012 10:28

Re: Downtime and new server
 
Quote:

Originally Posted by BrandonC (Post 1699813)
So is the move to the new host permanent, or just until the new server is up?

It depends if the new host is able to hold all the sites (I have other sites hosted there too). That's why I ask for your feedback on the server's responsiveness.


Quote:

Originally Posted by Greeney (Post 1699815)
If people are still going to UtopiaTemple.com (instead of forums.utopiatemple.com) they won't realize the forum is open.

I plan to restore the main site today. In the meantime, as Swifty said, there is a link to the forums.

BrandonC 18-Mar-2012 15:21

It seems a little sluggish, but not terrible.

Also, I have to log back in every time I leave the site. The "Remember me" box doesn't seem to be working (for me at least).

Brother Green 18-Mar-2012 15:38

Re: Downtime and new server
 
Quote:

Originally Posted by BrandonC (Post 1699820)
I have to log back in every time I leave the site. The "Remember me" box doesn't seem to be working (for me at least).

Yeah, there was a problem with the login cookie, but it should be fixed now. Please let me know if it happens to you again.

Also, good news, the main site is back online! :D


All times are GMT+1. The time now is 20:16.

Powered by vBulletin (modified)
Copyright © Jelsoft Enterprises Ltd.