Utopia Temple
Main Forum Page Register an Account for Free! Calendar Frequently Asked Questions about this Board View New Posts Advanced Search Login
  Utopia Temple Forums > Utopia Angel > Report Bugs and Problems

« Previous Thread | Next Thread »
  Post New Thread Reply
Author Thread
Posts: 1/7
(29-Jan-2003 at 22:25)
runtime error 217 at 00107f89

I get this error starting angel 1.40b whenever anything is present in the clipboard. Clearing the clipboard stops this from happening.
#1  
View Public Profile Find more posts by monkeystrangler Add monkeystrangler to your Buddy List Reply with Quote
Posts: 566/1369
Donated $2.64
(30-Jan-2003 at 10:10)


what operating system do you use?

what browser do you use?

do you happen to have java runtime environment installed? (java runtime can be found here
the java runtime is needed for some applets to be able to start, and some (especially older) browsers need to have this running apart to start applets.

Blood Raven
Former Head investigator of the HappinessFormulaeandIndicators of age 17 through 25.
Creator of the (now outdated) TipsandTricksGuidetoUtopia!
Haven't played Utopia in several years now. But i have returned
#2  
View Public Profile Visit Blood Raven's homepage Find more posts by Blood Raven Add Blood Raven to your Buddy List Reply with Quote
Posts: 17/45
Donated $2.64
(31-Jan-2003 at 23:37)


It happens with me aswell, I am runnig Win ME but it only seems to happen when it is used for the first time after starting the PC. It does sometimes happen afterwards though.
Attached Images
File Type: bmp runtime error.bmp (50.4 KB, 17 views)
#3  
View Public Profile Find more posts by markdigi Add markdigi to your Buddy List Reply with Quote
Posts: 2/7
(02-Feb-2003 at 19:36)
Currently

running Win 98SE, browsers are Opera 6.05 and IE 5.5. Java runtime is one that came with Opera 6.05. (version 1.3.1)

The problem appears to be the way Angel v1.40b handles clipboard data upon starting up. If I start angel, and ANYTHING is in the clipboard, no matter what it is, I get that specific error. If I then clear the clipboard, angel will start happily. It doen't appear to be browser or OS related problem, because ever previous version of angel, from version 1.20 seems to have worked fine with mu system the way it is. 1.39 also seemd to work fine, and the base config of my system hasn't changed at all between the versions.
#4  
View Public Profile Find more posts by monkeystrangler Add monkeystrangler to your Buddy List Reply with Quote
Administrator
Posts: 4890/8414
(15-Feb-2003 at 21:20)


lightbulb Re: runtime error 217 at 00107f89

Java has nothing to do with it. Please try to run Angel with the /clearreg switch.

Brother Green, Utopia Angel creator.
#5  
View Public Profile Find more posts by Brother Green Add Brother Green to your Buddy List Reply with Quote
Posts: 18/45
Donated $2.64
(19-Feb-2003 at 22:20)


Its also present in the latest Angel version 1.41 Alpha 1 and where's the /clearreg switch?
#6  
View Public Profile Find more posts by markdigi Add markdigi to your Buddy List Reply with Quote
Posts: 106/107
(20-Feb-2003 at 01:12)
/clearreg

The /clearreg switch is something that you add on the the end of the "Run" line follow these simple intructions

If you are running Win95/98/98se (I Don't know about ME but I assume it's about the same.)

Click Start
Go to Run
Type in the following line subsitituing C:\utopia\angle for the directory where you installed angel:

c:\utopia\angel\angel.exe /clearreg

Click Run. You will recieve a message asking if you want to clear all of the Angel settings and the Archive. Click Yes. Then rerun angle as normal.

the "/clearred" is called a switch it denotes to run the program a specific way. In this case it restores Angel to it's original form.

A Wise man once said, "I have nothing to say so I said nothing."
#7  
View Public Profile Find more posts by tsrblke Add tsrblke to your Buddy List Reply with Quote
Posts: 13/35
(25-Feb-2003 at 22:28)


Mine is slightly different

I also get the "runtime error on line 217" error, though mine doesn't give the hex code afterwards. And I don't think it has anything to do with the clipboard since it happens even when i had just turned the computer on (hence nothing in clipboard). It's actually a very specific condition. I use the Opera browser, the newest one (7.01 i believe). When I start it I get a pop-up message informing me something called M2 hasn't not been configured (i think it's some service they charge for), clicking ok gets me to the browser.

Now, if i start angel after this M2 message has been done away with, it's ok. Or if angel his been running for some time and I start Opera, the M2 message comes up, i ok it, and it's all good. However, if i start Angel, then within a very short time start Opera the M2 message will come up and at the same time the "runtime error on line 217" error will come up, and then Angel crashes and closes. (very short time meaning i double click one shortcut, then the other.. i guess it turns into a race condition of some sort between Opera and Angel)

...---====oooOOOO000({[<*>]})000OOOOooo====---...
Early bird gets the worm, but the second mouse gets the cheese.
#8  
View Public Profile Find more posts by zkajan Add zkajan to your Buddy List Reply with Quote
  Reply

Thread Tools
Display Modes

Forum Jump:


All times are GMT+1. The time now is 11:23.

Powered by vBulletin (modified)
Copyright ©2000-2006, Jelsoft Enterprises Ltd.